Back to overview
Degraded

Conveo app log-in is down

Feb 19 at 04:30pm GMT
Affected services
conveo.ai

Resolved
Feb 19 at 06:48pm GMT

Our provider has notified us that the problem is resolved.

Created
Feb 19 at 04:30pm GMT

Due to our authentication provider failing, we're experiencing downtime on Conveo app login.